Selespeed oil leak - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 17-10-07 Thread Starter
Status: -
AO Member
Join Date: Aug 2005
Posts: 21

Member car:

gt jtd

Selespeed oil leak

Strange problem ,156 1999, selespeed works fine when oil filled to correct level but it loses oil out of the reservoir overflow when the car is switched off. The reservoir will be full to the brim with ignition switched off for a couple of hours as if it is being back pressurized. Any help welcome thanks.
abbey is offline  
Sponsored Links
Status: -
AO Silver Member
jug's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Images: 23
Re: Selespeed oil leak

fluid level rises as fluid settles. sounds like overfilling is the cause of the leak. only fill up when the car hasnt been used for a couple of hours.
jug is offline  
Status: Powered by coal and steam
Club Member
Membro Premio
EVEL's Avatar
Club Member Number: 1382
Join Date: Jan 2007
Location: England
County: West Midlands
Posts: 9,808
Images: 7

Member car:

alph a ramayo

Re: Selespeed oil leak

I agree with jug . to check level turn key to mar , first click . If it is over full it will find its level by losing the oil thru the breather tube . You can attatch a bottle to the end of the breather to see how much your losing . Mine did have this problem but it was down to too much pressure in the actuator it should be around 50bar mine was 75bar had to replaced actuator . Have a diagnostic check done for peace of mind , As jug said it sounds like you've just over filled it , dont panic yet . Let it find its own level
EVEL is offline  
Status: -
AO Member
Join Date: Aug 2007
Posts: 10
Re: Selespeed oil leak

Hi, i had a similar issue today. I topped up my selespeed oil just after turning off the car because it looked low. When i came out again i noticed oil under the car and it looked like it was coming from under the resivour. My mechanic said he did notice a really small leak from the gearbox about 6 weeks ago, but there has never been any oil on the ground before. Do you think it was just a case of over filling?
hev_nas is offline  
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: Selespeed oil leak

Switch on ignition, pump activates, select a few gears, check level. Does a fair bit of work, at a reasonable pressure, (I'm with the 300,bar club with my hobby mods at the moment) so if it's overfilled, it will puke some out. So long as it doesn't lose the lot.: With the correct undertray in situ, the foam soaks the odd spew up, so get that tray, save that spotless garage floor. Sele posts so AM'ish? laters if you please.
zulu ferret is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

leak , oil , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome