147 exhaust problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 27-10-15 Thread Starter
Status: -
Join Date: Oct 2015
County: -
Posts: 2
147 exhaust problems

I'm new to the Alfa scene, so I thought I'd start with a 2002 147 1.6 T-Spark. It's been great and I've definitely court the bug. 4 months in and I'd no problem but my exhaust started blowing, so I had it checked. It seems that everything from the manifold and cats, all the way to the back box needs replacing. Been quoted £560 fitted but the car only cost me £600, so I thought I'd have a look myself first. The middle boxes and back box are easy enough to find, about £55-£80. But the manifold, 2x cats and flexi pipe are a little harder to find. Just thought I'd put my problems out here to see if anybody had any ideas or could point me in the right direction.
kjmather is offline  
Sponsored Links
Status: got a new busso s.w.
AO Silver Member
gibot123's Avatar
Join Date: Aug 2013
Location: United Kingdom
County: East Sussex
Posts: 1,670
I don't know where you are based but try ebay or one of the indie garages on here like Autolusso .They will probably be able to help with s/hand manifold pipe etc...
gibot123 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , exhaust , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome