156 Rear Transverse Arms - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 08-10-07 Thread Starter
Status: -
AO Member
stivh's Avatar
Join Date: Aug 2007
Location: Manchester
Posts: 40

Member car:

156 2.0 TS

156 Rear Transverse Arms

Hi folks

I have managed to buckle my rear offside long Transverse Arm driving out of my rocky driveway. So now that my back end feels a little light headed I shall have to replace it.

So while I am there do I need to buy any other parts or can this just be replaced, do I need new bushes, is it best to replace them on both sides, I am not keen on throwing money at it but at the same time don't want to start re visiting the same area to replace a part that has failed because something down the chain of links has been replaced.

I was going to use EB Spares in Wiltshire for the parts and am looking for somewhere near Manchester to check my wheel alignment afterwards so any help there would be appreciated.
stivh is offline  
Sponsored Links
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,289
Images: 12
Re: 156 Rear Transverse Arms

Bars come with bushes, but check the small hub bush while you are under there ... it's the one mounted in the hub assembly and connects to the TRAILING arm (the ones that run forward, not across).

I think the issue will be the mounting bolts so be prepared with some new parts and possibly some hacksaw blades, etc!
gazza82 is offline  
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: 156 Rear Transverse Arms

Had to replace the o/s on her 147, which was bent, when we first got it. Nice easy, no hassle job, so no real problems, unless like Gazza says you are up against rust and seizure.:
zulu ferret is offline  
(Post Link) post #4 of 4 Old 10-10-07 Thread Starter
Status: -
AO Member
stivh's Avatar
Join Date: Aug 2007
Location: Manchester
Posts: 40

Member car:

156 2.0 TS

Re: 156 Rear Transverse Arms

Sprayed all with WD 40 has looking rusty, once ordered will wait for the parts to arrive before I try and seperate everything.

So many thanks peeps this is a work in progress so will let you know how got on - fingers crossed it stays a simple fix.

Do I need to get the Tracking done as it is just a straight forward like for like replacement?
stivh is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , arms , rear , transverse

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome