Bella went to stealers today! :( - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-10-07 Thread Starter
Status: -
AO Member
canox's Avatar
Join Date: Jun 2007
Location: South Africa
Posts: 19
Help Bella went to stealers today! :(

i have been having selespeed issues since 2 days ago. System errors kept on coming up. Eratic gear problems (wouldnt change out of thrid, car going into neutral etc....the usual problems.).

TODAY (a freakin MONDAY!), the car gave hell on the way to school. gear changing was horrible, slipped into neutral twice. I got to school, turned the car off and as I got out I heard the selespeed pump going. The pump did not go off! just kept on going....i left it, came back later and smellt a sharp burining smell....well then that was it! No changing at all, the pump wasnt turning on etc...

We then towed it to the stealers and it seems that they know what they are doing (i hope!)...just worried about the price....perhaps a new pump?

Anyway, if anyone has any ideas as to what the problem could be, let me know!.

Thanks what a horrible monday....
canox is offline  
Sponsored Links
Status: 660Nm of torqueystuff!
AO Platinum Member
Hunter's Avatar
Join Date: Dec 2004
Location: British Indian Ocean Terr
County: -
Posts: 15,150
Images: 37
Re: Bella went to stealers today! :(

Not a good start to the week!

Good luck
Hunter is offline  
Status: -
AO Silver Member
jug's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Images: 23
Re: Bella went to stealers today! :(

buy selespeed have pain.
jug is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bella , stealers , today

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome