Sun roof problem on 2002 147 Lusso - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 08-10-07 Thread Starter
Status: -
AO Member
Join Date: May 2007
Location: ireland
Posts: 21

Member car:

147 Lusso

Sun roof problem on 2002 147 Lusso

Hi All,

I've searched the forum under sun roof problems but haven't really been able to find an answer to my problem.

Last Saturday when driving the car I opened my sun roof to the fully retracted and open position. I did this by pressing the manual arrow button (this button points in the direction of the back of the car). When I tried to close the sun roof by pressing the C button it would not close, which is strange as the C button always closes it for me without problems. I was able to close it manually by pressing the arrow button (which points in the direction of the front of the car). The problem with using the arrow button to close the roof is that you cant tell from sitting inside the car if the roof has closed properly. I had to stand outside the car and check to see that the sun roof was closed properly and watertight.

At the same time the C button inexplicable stopped working, the 1 and 2 buttons stopped working also. I'm not sure if the sun roof's on the alfa 147's are standard, but on mine I have 5 buttons to control it's setting:

1 = opens it automatically to a slightly open and tilted position

2= opens it automatically to a fully retracted and open position

C = closes the sun roof

▲= closes the sun roof manually

▼ = opens the sun roof manually

On the same day the 1, 2 and C buttons stopped working, I expereinced another problem with the sun roof which is as follows:

Previously whenever I stopped the car and turned off the ignition, if the sun roof was open it would close automatically without me having to touch anything. That function also has failed to work since Saturday.

So for no reason at all, the only buttons that work on my sun roof are the manual ones (▲, ▼). Has this happened to anyone before, or can anyone explain what happened, or more importantly what I can do to get the 1, 2 and C button's working again?

dihedral is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , 2002 , lusso , problem , roof , sun

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome