Back to Alfa Ownership - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 1 Post By dazsowden
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-10-15 Thread Starter
Status: It's far to early to think straight
AO Member
dazsowden's Avatar
Join Date: Mar 2010
Location: United Kingdom
County: Devon
Posts: 52
Images: 12
Back to Alfa Ownership

Hi guys, back with Alfa after 5 years or so off. Its only my second Alfa, both 156 but the last one was riddled with problems and nearly managed to put me off them for life. Still, here we are, this time no Selespeed :-) Nice little 1.8 Veloce, what a car, everything you hope an Alfa would be. The only issue with her is the speakers occasionally crackle and go off, very annoying while listening to your favourite track. Whats the most likely cause, the stereo itself or speakers. Also, what's the best speaker upgrade?
ALFADOIT likes this.
dazsowden is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Nov 2013
Location: United Kingdom
County: Gwynedd
Posts: 1,147
If it is only 1 speaker it is likely to be loose connection between the door and hinge. This is a 1 inch diameter round grey plug held fast with a metal clip. Undo the clip with a pinch and a pull. Then clean it with solvent, wd 40 or contact cleaner. Reassemble.
dgmayhead is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , back , ownership

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome