GT 2007 turbo issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 1 Post By _The_Editor_
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 19-10-15 Thread Starter
Status: -
Join Date: Oct 2012
Location: United Kingdom
County: Bristol
Posts: 2
GT 2007 turbo issues

I have had multiple issues with my turbo, on the third turbo now and shows indications of failing also - what could the issue be. My mechanic has met given up as he has tried all he can. Please help
Jry is offline  
Sponsored Links
Status: -
AO Member
samsdads156jtd's Avatar
Join Date: Apr 2015
Location: Renfrew
County: Renfrewshire
Posts: 112
What are the failure modes for the turbos? do you have a blocked oil feed to the turbo unit? were the other turbos new/reconditioned or secondhand?
samsdads156jtd is offline  
Status: Flaps? What flaps?
AO Silver Member
_The_Editor_'s Avatar
Join Date: Oct 2014
Location: United Kingdom
County: Devon
Posts: 2,199
What's the failure mode?

Might be worth sending off an old failed unit to a specialist turbo rebuild company, and they'll perform a post-mortem on it and tell you what killed it...
samsdads156jtd likes this.
_The_Editor_ is offline  
(Post Link) post #4 of 4 Old 26-10-15 Thread Starter
Status: -
Join Date: Oct 2012
Location: United Kingdom
County: Bristol
Posts: 2
Thanks for the reply guys. First two turbos were second hand, last turbo was a reconditioned one. I am unsure of the codes but I will ask my mechanic and get back. The oil uptake was a proble discovered early days but this is now fixed and oil pressure is perfect. Still the turbo begins to whine n show signs of failure after around an hour of idling
Jry is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

2007 , issues , turbo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome