wiper failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 05-10-07 Thread Starter
Status: -
Join Date: Aug 2007
Posts: 9

Member car:

alfa 147

wiper failure

woundering if anyone can help, ive got a 2002 147 and the wipers dont work on the slowest speed or if they do they only do a few wipes and then stop but if u have it on he middle or fastest setting they work fine, but once you turn them off you have to turn the engine off and back on again to get the wipers working again, was just woundering if any1 else has had the same problem and how they fixed it.
criton1988 is offline  
Sponsored Links
Status: Generating blue smoke. Lots of it!
Club Member
Membro Premio
Probusterrace's Avatar
Club Member Number: 25
Join Date: Jul 2006
Location: United Kingdom
County: Shropshire
Posts: 2,701
Images: 14
Re: wiper failure

Not quite the same problem as with mine.

On two occasions now my wipers have just stopped functioning completely. Both occasions in rainy conditions. The first whilst queuing to get into NAD last year, so fortunately I was going fairly slowly and not on a public road.

The second occasion was this morning and in more difficult conditions; Rain and motorway spray travelling at 70 on the M6 Toll, so I had to stop at the services which were fortunately only a mile away.

Solution both times was to turn engine off and then back on. Wipers re-started and off I go again!

Not escatly confidence inspiring!

60% of the time it works everytime.
Probusterrace is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

failure , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome