147 CF4 engine issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-10-15 Thread Starter
Status: 147 DC,
AO Member
2tone's Avatar
Join Date: Jul 2009
Location: United Kingdom
County: Buckinghamshire
Posts: 78

Member car:

147 DC

Unhappy 147 CF4 engine issues

i have a 147 with CF4 engine , and have had egr blanked and patched in software. i have also had the metal swirl flaps removed and software patch installed.
my question is what sort of problems/issues has anyone had after doing this mod. my MPG is at best 39mpg and although the performance is pretty good i have great plumes of smoke out the back at various times , usually after coasting along and then accelerating
i have put cataclean through once, i have checked and cleaned carefully the MAP & MAF sensors, also checked pipework for leakages or holes, i think the car is overfuelling.
Should the swirl flap holes be blocked, or maybe a rolling road/remap.
What problems/issues has anyone else had?
2tone is offline  
Sponsored Links
Status: -
AO Member
djs93's Avatar
Join Date: Mar 2013
Location: United Kingdom
County: Cheshire
Posts: 367

Member car:

Mito Cloverleaf

I've considered removing the swirl flaps too, but have decided against it as I've read mixed reviews on here about people that've had it done. My plan is too blank off the egr soon then when my next cambelt change is due, probably renew the inlet manifold and hope the flaps stay intact.
djs93 is offline  
Status: Past the dodgystageof life!!
AO Silver Member
Llanrads's Avatar
Join Date: Nov 2009
Location: United Kingdom
County: Carmarthenshire
Posts: 2,589
Images: 17
When i had the head off my jtdm 147 i had all the valves cleaned and ground cleaned the egr valve the flaps and manifold re assembled and it runs perfectly. All standard now and drives like a dream . Just completed an 800 mile round trip to Cumbris (Honnister Pass) and over to North Yorkshire and hoe to South Wales . Perfect,, and 49 mpg with some enthusiastic driving.
Llanrads is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , cf4 , engine , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome