re:problems with overheating 156 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 02-10-07 Thread Starter
Status: -
Join Date: Sep 2007
Posts: 4
Wave re:problems with overheating 156

hi all,
i've just bought a 99 156 20its and it seems to be having a problem with overheating help!pls..It seems to take 5-10mins to warm up to around 75-90 but when it gets there it just seems to keep going up to around 100-105 and then mabey drop a little but generally tends to stay at this temp. Having to regulate the temp with the ac on full blast.i've checked the fans they seem to be working.Could it be the thermostat?.There also seems to be alot of back pressure in the coolant system as when i went to take off the cap for the water expansion bottle it started to bubble fiercly.Can any1 help?
martin2728 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , overheating , reproblems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome