Selespeed Selector Shaft or Gearbox? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 07-10-15 Thread Starter
Status: Selector problems
AO Member
Join Date: Sep 2009
Location: United Kingdom
County: Lincolnshire
Posts: 59
Selespeed Selector Shaft or Gearbox?

My previously mentioned difficulty with engaging reverse has been linked to a number of issues but it seems that a worn selector shaft is the issue. It seems to be worn and wobbles around like a spoon in a mixing bowl so that it sometimes similtaneously displays, selespeed warning light, 1st Gear 2nd Gear and beeping! switch up to third and it is fine, slow down towards a roundabout for example and as soon as the auto downshift goes through 2nd, it all goes as above.
Rod has been set 2 weeks ago. No leaks. Selenia always used.
Do I need to replace just the shaft, or the whole gearbox?
Any musings welcome.
PauloLindum is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

gearbox , selector , selespeed , shaft

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome