connect nav nightmare - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 27-09-07 Thread Starter
Status: -
Join Date: Sep 2007
Location: United Kingdom
County: South Yorkshire
Posts: 4

Member car:


connect nav nightmare

Hi, when i got my alfa 147 the connect nav language was set to italian. When i try to change it to english i think it's asking for a cd, but i never got one with the car. Any ideas of how to fix this or where i can get the required cd.
padadam is offline  
Sponsored Links
Status: Never went to Jamie's Dream school!
AO Silver Member
Jed's Avatar
Join Date: May 2006
Location: Brighton, UK
Posts: 4,759
Images: 5

Member car:

Rosso GT

Re: connect nav nightmare

If you send a very nice PM to Ned ("Autolusso") on this forum, he may well be able to supply you with one of his "spares" (if he has any).

I had a similar problem after a "reset" on the system. Ned kindly sent me the said installation disc and Bob (rather than Barbaro) is you uncle again
Jed is offline  
Status: -
AO Member
gorf1971's Avatar
Join Date: Sep 2007
Posts: 319
Images: 3

Member car:

alfa 159 2.4 TI

Re: connect nav nightmare

Hi Padadam

have a look at the thread below. If you do a search on connect in the forums i remember reading a thread a few days ago where somebody had an image of the cd i think they got it off ebay. i've had a quick look but cant see the same thread at the moment. The method described in the thread below seems to have worked for a few people.
gorf1971 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

connect , nav , nightmare

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome