156 jts hesitation - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-09-15 Thread Starter
Status: -
AO Member
Join Date: Jul 2013
Location: United Kingdom
County: Kent
Posts: 29

Member car:


156 jts hesitation

Hi all had slight hesitation under 2000 revs ,no idling problem, no problem on acceleration just at part load ,just changed fuel filter 2003 model no change any ideas ?
alfamat4 is offline  
Sponsored Links
Status: -
AO Member
SpoiledGT's Avatar
Join Date: Dec 2014
Location: United Kingdom
Posts: 143

Member car:

Gt 3.2 v6

Usual suspects are split air intake after filter, exhaust leak near downpipe or flexipipe, or maf/lambda sensor faults. Put it on a diagnostic and see if any error codes come up. They don't always throw up an engine management light.
If not then it may be injectors which is a time consuming and expensive fix
SpoiledGT is offline  
Status: Fixing my Busso
AO Member
valinco's Avatar
Join Date: Sep 2014
Location: United Kingdom
County: Tyne and Wear
Posts: 776
Images: 2

Member car:

156 V6 SW

It's more than likely going to be an intake problem, maybe loose clip or split somewhere. Try cleaning the maf as well.
valinco is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , hesitation , jts

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome