Possible weird sound from motor - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 24-09-15 Thread Starter
Status: -
Join Date: Jun 2015
County: -
Posts: 4
Possible weird sound from motor


The car is a 2005 GT that has gone 110 000 km.

To keep it short: A couple of days ago, on the highway, I needed to shift gear to idle. Doing this, the RPM dropped to idle (approx 1000?), while still moving at considerable speed (110-120 km/h). I then shifted again to the fifth gear, as careful and gentle on the clutch as I could. However, it still was kind of a fast reving up to 3-4000 rpm. At the same time I got the dreaded "Motor control system failure" error. I immediately shifted to idle again and stopped at the side of the highway.

I shutdown the car, swore a little (that means a lot), then tried starting it again. No error message, nothing sounded or felt wrong from inside the car. I started driving, nothing has changed compared to earlier with regards to the car handling or acceleration. I stopped at the next suitable place. Listened, reved, opened the hood, but couldn't notice anything strange. I googled for a couple of hours, but came up short of an explanation.

Today, a couple of days later, I went outside the car with it in idle. When I heard the motor sound from outside, I got the feeling that something, altough I can't pinpoint what, sounds different than before. A "rattling" sound wouldn't be entirely true, but it's the best I can come up with. It's hard to say since I haven't had the car for more than three months and I'm not particularly experienced with car motors and how they should sound. It sounds good while reving, it's mainly when the car is in idle that it sounds "weird". Also, when idling standing still with the door open, I've felt a faint smell of gasoline-ish (but not spot on) smell with a hint of something burnt-ish in it.

My question is, do you think something may have broke? What are the usual suspects when reving fast from 1000-4000 rpm? Or am I just imagining things?
cooflar is offline  
Sponsored Links
Status: Race cars in progress
Club Member
Membro Premio
Gertie's Avatar
Club Member Number: 2201
Join Date: Oct 2007
Location: South Africa
County: Gauteng
Posts: 5,251
Images: 6
Sorry mate - that is a bit vague to try and guess something from this side... Firstly, what engine?

Best to get it to a macchie
Gertie is offline  
Status: -
AO Member
SpoiledGT's Avatar
Join Date: Dec 2014
Location: United Kingdom
Posts: 143

Member car:

Gt 3.2 v6

If it's a 2.0 petrol it could be the variator on its way out. Does it sound like a diesel engine at idle?
SpoiledGT is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

motor , sound , weird

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome