Ticking/Clicking noise from the wiper stalk - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 22-09-15 Thread Starter
Status: -
Join Date: Nov 2014
Location: United Kingdom
County: Cornwall
Posts: 1

Member car:

Alfa 147 2.0

Hmmm Ticking/Clicking noise from the wiper stalk

I've just got my second Alfa, and it's awesome, except, the horrible noise coming from the wiper stalk, it sounds like a morse code tap really quickly.
I know it's this because flicking the wipers on, or even changing the intermittent speed makes it go away (normal speed, ticking, 1 click and the ticking stops, 2 clicks and it's back, then turn it again and it goes again! weird)

Mine's a 147 JTDm 16v

There's a couple of forum posts about it but not with anything useful, does anybody know how to solve or potentially solve this?!


Last edited by spacepills; 23-09-15 at 09:09. Reason: Didn't mention my model!
spacepills is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

noise , stalk , ticking or clicking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome