156 hissing noise when I indicate. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 26-09-07 Thread Starter
Status: -
AO Member
Join Date: May 2007
Posts: 14

Member car:


156 hissing noise when I indicate.

Help needed!
My 52 plate 56 1.8 twin spark has started to make an intermittent kind of hissing noise when I indicate.
Anyone encountered this? i'm thinking it may be a battery issue.
buster is offline  
Sponsored Links
Status: Running on fumes
AO Member
rathkennades's Avatar
Join Date: Feb 2007
Location: Dublin, Ireland
Posts: 187

Member car:

MiTo Cloverleaf

Re: 156 hissing noise when I indicate.

??? Battery issue?

What kind of hissing noise, is it from the radio, the engine, the exhaust, the wheels, the aircon system? Have you left the windows open a crack?

Sorry, not being smart, it's just a very vague description of a problem is all!
rathkennades is offline  
Status: -
AO Gold Member
Join Date: Jul 2006
Posts: 7,178
Re: 156 hissing noise when I indicate.

Change the battery.

Dey doo dat dont Dey?!!
cj romeo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , hissing , noise

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome