Selespeed Pump Help Needed! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 23-09-07 Thread Starter
Status: -
AO Member
Join Date: Dec 2006
Posts: 36
Images: 5

Member car:

Alfa 156

Hmmm Selespeed Pump Help Needed!


I have diagnoised that the fault with my selespeed is the pump.

I took the plastic cover off and gave it a whack and it starts up, now i have started to unbolt it, but cant take it out completley because that means draining the system, and i dont have the money or "means" of getting to the garage to get selespeed oil.

Can you firstly tell me:

1: if i take the pump apart and clean the brushes should this help?

the pumps always kicking in when i open the door now, but the bumps on the road seem to make it stop again, what could this be?

I know its late but im really hoping to take the car 45miles to bodmin tommorow evening and would like to think i have fixed it. Any help or tips for a "quick fix" would be really appreciated.

Kind Regards
Edward Salatas
01326 566608
07935 216000
edwardsalatas is offline  
Sponsored Links
Status: -
AO Member
felix's Avatar
Join Date: Mar 2004
Location: United Kingdom
County: West Midlands
Posts: 34
Re: Selespeed Pump Help Needed!

If youre careful you wont lose much oil when you remove the pump, have a small container handy to catch any that spills out, you can then put it back in when you have finished.

The pumps are not the easiest things in the world to take apart. The brushes in mine were totally shot and needed replacing. I ended up using some from a wiper motor that i had kicking about in some sample parts i had at work.
felix is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

needed , pump , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome