147 SS Brake fail? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 1 Post By dgmayhead
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-09-15 Thread Starter
Status: -
AO Member
Join Date: Mar 2012
Location: United Kingdom
County: Greater London
Posts: 263
Images: 10

Member car:

156GTA 147SS

147 SS Brake fail?

Mrs was driving her SS yesterday and the brake pedal went soft and did not work - after the initial screaming and panick I found the brake pedal was travelling all the way down but then sometimes seems to come back to normal pressing position. There are not many topics covering this but somehow got the car dropped off to the mechanic - is there anything I should be looking out for, or an order for inspection to avoid them pulling the wool over my eyes?

Thanks in advance,

GTV_Slave is online now  
Sponsored Links
Status: -
AO Silver Member
Join Date: Nov 2013
Location: United Kingdom
County: Gwynedd
Posts: 1,147
I think you have to trust your mechanic. As long as he doesn't want to fit a new flux capacitor he should be able to diagnose.
GTV_Slave likes this.
dgmayhead is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , brake , fail

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome