New accelerator pedal - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 22-09-07 Thread Starter
Status: -
AO Member
Join Date: Jan 2005
Location: Birmingham
Posts: 222

Member car:

02 156 2.4 JTD

New accelerator pedal

It looks like my Alfa is going to need a new accelerator pedal. After trying to solve the problem of it cutting out due to a high resistance reading, by putting some copper slip on the connector it seems to of partially succeeded by making the problem less noticeable and frequent as it only appears when driving around town, rather then at all speeds.

How much is this roughly going to cost me?
NeilB is offline  
Sponsored Links
Status: Paternal
AO Silver Member
Simon_S's Avatar
Join Date: Oct 2001
Location: United Kingdom
County: Warwickshire
Posts: 1,322
Images: 5
Re: New accelerator pedal

Hi Neil,
Have you checked the sensor out? DTE shows the pedal sensor consists of two 1kOhm pots, one on pins 1, 2 & 3 and the other on 4, 5 & 6. 1 & 4 are the sense pins with 1kOhm series resistors so check that the resistance on these changes smoothly as you move the pedal.
It might be possible to dismantle the potentiometer and clean the tracks inside to restore it to health for nothing - worked a treat on the moving flap air flow meter on my Mk2 Golf GTI.
Simon_S is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

accelerator , pedal

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome