156 Power Steering.... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
156 Power Steering....

I've had my 156 (x-plate) for a couple of months now, and I've noticed that sometimes (not always) after the car has been standing for some time (like overnight or a shift at work) whjen I get back in and start her up, the power steering doesn't kick in straight away.

The wheel feels heavy and cumbersome, and then after a minute or two....

It releases, and the power steering is fine, light and comfortable.

As I say, it doesn't always do this, some mornings it starts up and the steering is fine

Anyone got any ideas?
Sponsored Links
Status: .
AO Silver Member
Rob3rto's Avatar
Join Date: Sep 2004
Location: I would rather not say
County: -
Posts: 2,519
Images: 6

Member car:


Re: 156 Power Steering....

I presume you have checked fluid level?
Rob3rto is offline  
Status: - Update
Posts: n/a
Re: 156 Power Steering....

Originally Posted by Rob3rto View Post
I presume you have checked fluid level?
I have and it seems fine. It's the fact that the problem is intermittant and almost random that's got me puzzled ]

I got a 6 month warranty on the car though, so best get it checked out. Thanks anyways.
Status: only got a renault truck
AO Silver Member
jason156's Avatar
Join Date: May 2007
Location: United Kingdom
County: Powys
Posts: 3,013
Images: 10
Re: 156 Power Steering....

Does the oil look clean ?
Is the drive belt to the pump slack?
jason156 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , power , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome