Alfa GT 1.9JTDM Reverse lights and parking sensors not working. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 28-08-15 Thread Starter
Status: -
AO Member
Join Date: Apr 2014
Location: United Kingdom
County: West Yorkshire
Posts: 15
Images: 2
Alfa GT 1.9JTDM Reverse lights and parking sensors not working.


I was just looking for some advice from some friendly advice.

I've read the threads about non working reverse lights and true enough the sender wire is snapped, I can't repair it as the break is too close to the connector.

Can new connectors be bought? I tried to take the existing one to pieces but the are quite fragile and it is now broken.

What would you guys suggest?

R30CMO is offline  
Sponsored Links
Status: Still love it
AO Member
Peter Simo's Avatar
Join Date: Aug 2012
Location: United Kingdom
County: Merseyside
Posts: 258
Images: 32
Try and pick one up from a breakers. They are fragile though.
Peter Simo is offline  
Status: Spanner wary
AO Member
Join Date: May 2013
Location: Spain
County: Malaga
Posts: 303

Member car:

Alfa 147 1.9jtd

Really not worth searching through breakers, easier to buy a new connector and fix properly (147 Reverse Light Switch Wiring Repair)
I quote
"For information - the plug used is a bog standard AMP Superseal 1.5mm 2-way and they can be purchased for about 1.50, so it isn't worth the hassle trying to bodge back the original one. "

Easy to find online
imski is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

19jtdm , alfa , lights , parking , reverse , sensors , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome