Has any one ever fitted an Alpine CDE-9850Ri to their 147? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 12-09-07 Thread Starter
Status: My 159 is a bird poo magnet
AO Member
Irish147's Avatar
Join Date: Nov 2005
Location: Ireland
County: Limerick
Posts: 387
Images: 1

Member car:

159 1.8 Turismo

Has any one ever fitted an Alpine CDE-9850Ri to their 147?

Hello all..
I want to fit an Alpine CDE-9850Ri to my 147 but I am unsure if I will need connecters to hook it up to my speakers, I am hoping its just a plug and play job.....any help??

Irish147 is offline  
Sponsored Links
Status: -
Join Date: Mar 2007
Posts: 5

Member car:

alfa 156

Re: Has any one ever fitted an Alpine CDE-9850Ri to their 147?


My reply is a bit like like comparing apples with oranges with potatoes but hope it helps here goes ...

I fitted an Alpine 9871 recently to my 156. It was very straightforward, as you say plug and play.

Had to think about which was the right +ve lead to connect because alfas don't provide power from the ignition. But this wasn't a problem.

reades is offline  
Status: bought a 75 3.0
AO Silver Member
155 Lounge Winner 09
shiny_car's Avatar
Join Date: Dec 2006
Location: Australia
County: Victoria
Posts: 7,669
Images: 39

Member car:

GT . 155 . 75

Re: Has any one ever fitted an Alpine CDE-9850Ri to their 147?

if the alpine comes with ISO connectors, then it is mostly plug-and-play. otherwise, you should buy a wiring adaptor harness to allow this.

only other issue may be the 2 powerwires: main 'constant' (IGN) +12V wire and trigger 'ACC' (switched) +12V wire. these can be swapped around in alfa's. you should use a multimeter/voltmeter to confirm these wires before connecting it up. if they are swapped around, then you will lose 'memory' like radio presets, and the headunit will also be using main power from the smaller gauge ACC wire, which isn't suitable either (at high volumes/consumption).

GT . 3.2 . Q2 . Kyalami Black - Red . Eibach . KONI . ASSO . ATP 19" . TAROX . FERODO . Mille Miglia exhaust
155 . 2.0 8V TS . Grigio Grey - Grey . H&R coilover . Enkei 17" . TAROX . GOODRIDGE . REMUS
75 . 3.0 . Alfa Red - Grey
shiny_car is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alpine , cde9850ri , fitted

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome