central locking and window problem! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 20-08-15 Thread Starter
Status: now a diesel head..
AO Silver Member
Join Date: Sep 2014
Location: United Kingdom
County: Surrey
Posts: 1,492
central locking and window problem!

OK ,just got woken up by my alarm going off, annoying in itself but as I investigated the problem in the dark two ''other issues'' come to light.

1) drivers side window would go down but not up after much fiddling I went through a process of opening an closing drivers side door until the window went ALL the way down at which point it was happy to go back up, I then left the door open and went around and disconnected the battery( if I close the door without disconnecting the batt then the window steps down and does not go back up without going through the whole annoying procedure again.

this has secured the car for the night at least anyway...

I noticed the door lights (the red ones in the bottom of the door) stayed on, so as far as I can work out there must be a switch in the passenger and drivers door that tells the ecu when the doors are open, I would imagine this has failed causing the alarm to go off as the car thinks the doors are wide open.

when going through the process of central locking I noticed the drivers side locks as does the boot but the passenger side won't lock..this would suggest the issue is there...?

BTW I recently changed the drivers side door handle and it has been raining all day and most of the night here..

I suspect the gremlin will go when it drys out and after a long battery disconnect but in the meantime can anyone shed some light on the problem and where the offending switch lives so I can re-check the wiring and perhaps give the switches a clean and or blast with a hair dryer..

I will probably buy a new switch of one is available and change anyway..

any thoughts you guys may have or if anyone else has had a similar problem and resolved it what as the fix?

edit: I also removed the drivers side window control and cleaned both connectors and socket with switch cleaner...no effect.



Last edited by joeymannero; 20-08-15 at 02:31.
joeymannero is online now  
Sponsored Links
(Post Link) post #2 of 2 Old 20-08-15 Thread Starter
Status: now a diesel head..
AO Silver Member
Join Date: Sep 2014
Location: United Kingdom
County: Surrey
Posts: 1,492

just in case anyone else has the same issue i am posting the cause and resolution..

as expected the fault vanished when the car dried out but I was aware the underlying issue was still there so went down to AL in bournmouth ,big thanks to Loz once again for fitting me in on a busy day at short notice and identifying and fixing the problem in double quick time..

so when fitting the new hinge to the door handle I had left a gap on the underside of about 2mm so the handle was not flush with the door, this allowed water to ingress over the last couple of days and short the microswitch that registers when the door is open or closed. so when the alarm was armed it kept going off, and of course the central locking would not engage and the window kept creeping down as if adjusting when opening and closing the door.

handle was refitted correctly and as the switches had already dried out its all now good.

hope this helps someone in the future.
joeymannero is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

central , locking , problem , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome