Motor Control System Alarm - Nightmare - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 09-08-15 Thread Starter
Status: -
AO Member
EdilioAlfa's Avatar
Join Date: May 2014
Location: United Kingdom
County: Cardiff
Posts: 28
Images: 6
Not Happy Motor Control System Alarm - Nightmare

I have recurring Engine Control System Alarm issues on my GT 2.0JTS. Its been on, then off and eludes repair. Had it into Alfa & Yapps in Cardiff. MAFF replaced and the alarm stayed off for 2 days. Now its back on. Returned it for further evaluation. Checked lambda sensors (all of them). Alarm off for two days and its back on again. Car runs fine, no power or delivery issues, but the alarm is still "ON". Really would like to get this sorted...
EdilioAlfa is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Apr 2008
Location: New Zealand
County: -
Posts: 2,240
If you tell us the error codes the MCSF is reporting, then we might be able to point you in the right direction. For the JTS, you can use an android phone with an appropriate app (Torque is the one I use) and an ELM327 bluetooth interface (10 quid from ebay) to check and clear fault codes.
sprint_veloce is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alarm , control , motor , nightmare , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome