Ran low on oil now have knocking sound. - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
Join Date: Jun 2007
Location: United Kingdom
County: -
Posts: 897
Originally Posted by symon View Post
Could also be just a tensioner...

Such a coincidence that the knock started just as it had run low on oil, but strange things do sometimes happen.
As Symon said, check crank pulley. Can make a very depressing sound indeed. I had one fail on a 1.9 TD Bravo and I also thought the engine was dead. I was able to pull on the outer part of the pulley and get a knocking noise which confirmed it.
gtv160 is offline  
Sponsored Links
Status: playing kill by numbers
AO Gold Member
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 7,708
1 litre of oil is enough in a 2.4 to get the oil light to go out, and stay out. I know this for a fact.

the min mark on the dipstick is right at the bottom of the stick, if adding 0.8l brings the level back on the stick, adding 2 litres in total will make it overfilled.

Find out where the oil went though, JTD engines shouldn't consume a noticeable amount of oil during a whole oci. Check the intercooler pipes, and the exhaust pipes if you can't find any leaks.

I've had knocking from the aux belt area which turned out to be a failing tensioner, but the crankshaft pulley isa definite possibility
Cuore_Sportivo_155 is offline  
(Post Link) post #28 of 28 Old 28-07-15 Thread Starter
Status: -
AO Silver Member
Join Date: Nov 2013
Location: United Kingdom
County: Gwynedd
Posts: 1,134
Hi again.
The oil loss volume was measured on a slope but I didn't get a warning light and I need to investigate where my oil went. I estimate 1.5 litres in 800 miles. Probably through my turbo. I will investigate later.

Anyway; with the aux belt off the noise is gone. Feeling the pulleys my alternator pulley doesn't spin backwards freely as it should. I would have assumed it had a fixed pulley but I found some excellent information from forum members regarding this issue and I am very grateful. It needs replacement.
dgmayhead is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

knocking , low , oil , ran , sound

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome