147 cruise control - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 30-08-07 Thread Starter
Status: -
AO Member
pgdrans's Avatar
Join Date: Aug 2007
Location: Cockermouth, Cumbria
Posts: 66

Member car:

147 1.6 Lusso

Help 147 cruise control

Coming back from Workington this morning, and though I would use the CC, It did not want to know. It has been working in the past, like 2 weeks ago. Just wondering if anyone else has experienced the same thisng, and if there is any DIY cure, Like Fuses etc and location of. before I kick ass.
I did make sure it was swithched on, and was all apearing normal.

If anyone has any ideas, I would be grateful

pgdrans is offline  
Sponsored Links
Status: -
Join Date: Aug 2007
Posts: 8
Re: 147 cruise control

i am too having problems, please check my thread for things that i have tried, and ideas from others.. good luck!!
tyketyson is offline  
Status: -
Join Date: Jul 2007
Posts: 2

Member car:

alfa 147

Re: 147 cruise control

It could be the switch on either the brake or clutch pedal - I think the brake pedal one is the most common one to fail they cost around 8.00 to 12.00 and I think the brake pedal switch is the four pin one - they are quite easy to change - might be worth a try if this does not work you will have to get the garage to plug the computer in to the car and see what fault it is showing.
gerald haynes is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , control , cruise

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome