Emmisions failure & erratic idle MAF replaced! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 27-08-07 Thread Starter
Status: -
AO Member
Join Date: Jul 2007
Location: Bristol
Posts: 135

Member car:

Alfa 156 2.4 JTD

Chilling Emmisions failure & erratic idle MAF replaced!

Hi Guys

I have a 156 2.0ts with 190000! miles on it! Its got a few problems as you would expect. It failed it MOT on a few things mainly mechanical which i have fixed now but also on emmisions. It only failed on Lambda passing CO & HC. I thought this would probably be asociated with the very erratic idle (hunting) so ordered a cheap replacment MAF from ebay. (it looked the same but was missing the "Bosch" badge and was from a seller with good feedback). The car now feels worse when cold and tickover when warm is just as bad. Anyhow seemed a bit different so i thought it was worh a go on the emmisions tester before changing again. Now failed emmisions on Lamda and CO! Have i brought a crap replacment MAF or could my problems be asociated with another component. Any help appreciated

Cheer Rich
tri_land is offline  
Sponsored Links
Status: -
AO Silver Member
armoore's Avatar
Join Date: Jan 2002
Location: United Kingdom
County: Surrey
Posts: 3,690
Re: Emmisions failure & erratic idle MAF replaced!

Cheap MAFs/AFMs have a poor reputation.

Also see for info. :-

armoore is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,612
Re: Emmisions failure & erratic idle MAF replaced!

Those cheap MAFs mostly don't work. Good feedback is due to people leaving it before fitting and testing the MAF, also sometimes they are slightly better than one that has broken, so it does give an impression the car is better, although it is far from perfect.
Pud237 is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

emmisions , erratic , failure , idle , maf , replaced

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome