147 JTD Brake Light Failure.. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-07-15 Thread Starter
Status: Alfa 4 Life.
AO Member
Join Date: May 2014
Location: United Kingdom
County: Oxfordshire
Posts: 167
147 JTD Brake Light Failure..

For few days I have this message coming up on the dash, randomly..for few seconds.. when the car is moving, never it's on when the car is stationary.. Strangely when the waring is on and I signal to right it is flickering quickly like one of the signaling bulbs is burned out.. but all the lights are working when the warning isn't on...

What could I start checking?

Last edited by Elvin; 06-07-15 at 14:14.
Elvin is offline  
Sponsored Links
Status: -
AO Member
Join Date: Nov 2007
Posts: 23
Check the connectors to the rear lights. The symptoms line up with a bad earth connection. It is likely this is at the connector block at the rear light unit. The earth connection is known to go high resistance, causing it to heat up, thus reducing the connector spring tension, making the connection even higher resistance and so on. The plastic of the connector housing can start to melt!
You need to clean up the contacts and bend the connector spring to grip the connector tightly again.
Nitram is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , brake , failure , jtd , light

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome