Alfa 156 2.0TS Sele. Warming up problems,strange working etc... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 02-07-15 Thread Starter
Status: -
Join Date: Mar 2014
County: -
Posts: 2

Member car:

alfa romeo 156

Alfa 156 2.0TS Sele. Warming up problems,strange working etc...

Hello! Maybe anyone know how solve my problem.
What i have. When i buy my Alfa( 1,5 Years ago), car is be warmed up, next day when i run it, i see the problem.
And now, i dont know what i need to change to be ok.
Car started normally, 1400rpm, then 1200, then ~900, and when temp is above 50C, engine start working strange,(i cant find a words to say how it looks)
at the sound looks like mini explosions on exhaust. Turn Key Off, then on, start, working normally.......and 1-2 minutes problem came back(or if i touch gas pedal)
AND When engine above 90C, working fine.
BUT i think my horses go away from my car....(1.6 l car faster....) 11.5sec 0-100!!(on selespeed), now i have manual gearbox, but car still slow)

what i replaced:
altenator(low charging voltage on prev)
spark plugs
ignition coils
ignition wires
fuel injectors
Temp sensor
RPM sensor
knock sensor
I checked the intake for leaks
Fuel Pump 3.5-3,6 BAR all times
oil - only selenia
I Dont know what i need to do(((

Sorry maybe sometimes you don't understand me, English not mine primary language)

Last edited by MobyDik; 02-07-15 at 19:56.
MobyDik is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 20ts , alfa , problems , sele , strange , warming , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome