Air Con issues. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-07-15 Thread Starter
Status: Chillin
AO Silver Member
Chocoboy's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 5,621
Images: 13

Member car:

2005 147 JTD

Air Con issues.

Hi everyone i have an issue with my aircon on my 05 147 JTD, basically after a recharge it's fine for about 6-8 weeks, after that though it starts to warm up again. Are there any common faults with the 147 system to look for before i get it in at an aircon repair place. when the recharge machines are plugged in they're not showing nay pressure faults.
Chocoboy is offline  
Sponsored Links
Status: - Update
Posts: n/a
Those machines are pants. I took my GTV to Kwik fit for a regas. It worked for a week or so.

Then Kwik fit re-regassed it. Again a week.

Local AC garage found the in-dash evaporator has a hole in you could get a biro through.

600 to replace.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

air , con , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome