GT Diesel Power Problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-06-15 Thread Starter
Status: -
Join Date: Jun 2015
County: -
Posts: 1
GT Diesel Power Problems

I am new so apologies that I may be going over some old ground.

On my 3rd Alfa 2 x 156 currently GT 2004 jtd (115000)
looked at EGR problems and have replaced mine albeit with a cheaper after market version - then ecu and throttle reset.

appears to surge every few seconds at constant speed not so much on acceleration which is a bit sluggish. Bit of black smoke on hard acceleration.
It runs better with the egr disconnected (engine light comes on but not for a few days) - still a bit sluggish but smoother.

Any help would be appreciated - thanks
Paul8364 is offline  
Sponsored Links
Status: Flaps? What flaps?
AO Silver Member
_The_Editor_'s Avatar
Join Date: Oct 2014
Location: United Kingdom
County: Devon
Posts: 2,199
If your EGR was funked, its worth checking your MAP sensor too as that is probably junked up too...
_The_Editor_ is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

diesel , power , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome