2.4 20v Vibrating Under Load - Driveshafts shot? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 03-06-15 Thread Starter
Status: -
AO Member
Join Date: Oct 2014
County: -
Posts: 14
2.4 20v Vibrating Under Load - Driveshafts shot?


Been reading a few posts on this but can't quite find the answer to a couple of queries. My 2005 2.4JTD 20V is has been vibrating when accelerating through the gears recently but only when there's passengers in the car. With just me driving its just a hint when revving harder (assume it will get worse though).
It had a new clutch and DMF less than 2yrs ago and no other symptoms so I am assuming its the driveshaft inner bearings from what I can gather.

I was quoted 400 plus 2hrs labour for each side for new parts. App you cannot fit just the bearings so it has to be the full driveshaft, which was a scary figure given the overall value of the car.

Is there an obvious way to ascertain if one side needs doing more than another? Someone mentioned they are unequal lengths and the long one tends to fail earlier.

What are peoples thoughts on original parts vs somewhere like CarParts Direct who say they do the correct complete driveshafts for 230 guaranteed for 2 years. Car Parts Direct | Driveshafts

Also how long does this problem last before it fails completely - its been getting more noticeable over the last few months esp when took it away on hols last week with the family + luggage.

Its not a job I would tackle myself so just after some help before I commit to s at the garage.

Many thanks for any assistance.

Last edited by dannyn; 03-06-15 at 15:27.
dannyn is offline  
Sponsored Links
Status: -
AO Member
gammakeith's Avatar
Join Date: Nov 2010
Location: United Kingdom
County: Nottinghamshire
Posts: 817

Member car:

156 JTD 2.4 20V

That's silly money - take it somewhere else eg Alfa specialist. I fitted a cheap (60) J&R driveshaft last year and its still fine! Unfortunately, J&R do not currently make the long one though so that would cost you more. Chances are it may just be the tripod bearing and if the cup is OK then a new bearing may sort it. You need someone to look at it properly and replace what is worn rather than throw two new (Alfa?) driveshafts at it.

gammakeith is offline  
(Post Link) post #3 of 4 Old 04-06-15 Thread Starter
Status: -
AO Member
Join Date: Oct 2014
County: -
Posts: 14

Yeah I thought it sounded ridiculous (it was genuine Alfa parts from the dealer).

Will take it to the other garage I used to use before I bought the Alfa and get them to have a look.
dannyn is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,618
Where are you based?
Pud237 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

20v , driveshafts , load , shot , vibrating

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome