Got my new 147, just a couple of things puzzling me! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 08-08-07 Thread Starter
Status: -
AO Member
Join Date: Aug 2007
County: -
Posts: 30
Got my new 147, just a couple of things puzzling me!

Hey everyone ,

Just been to fetch my new car - Alfa Romeo 147

Just a couple of things what are puzzling me, wondered if any of you guys could help!

Firstly, the stereo doesn't work! I need the code for it or something and the guy I bought it off has requested this from somewhere on the internet at a cost of 10, but it didn't work! Does anyone know what to do about this?

Also, the gears seem quite stiff. Obviously, like with any new car, it's just a matter of getting used to it compared to my old car but they really do seem overly-stiff. When in neutral, if I shove the gear knob to the left, then let go of it it just stays there. And its the same when I shove it to the right. So, when driving and changing from 2nd to 3rd, for example, it's pretty difficult. I'm having to take out of 2nd and then shove to the right and up to 3rd. It's difficult to describe properly but it really is quite stiff, is there anything I can do to ease it up a little?

Any help is greatly appreciated!

oxocube7 is offline  
Sponsored Links
Status: -
AO Silver Member
Kelly's Avatar
Join Date: Jan 2007
Location: Gloucestershire
Posts: 2,387
Images: 4

Member car:

147 2.0 TS Lusso

Re: Got my new 147, just a couple of things puzzling me!

Hi Danny

Don't know about the stereo bit...

But the gear changes could be quite easy to sort out. I had the same problem with mine when i bought it, took it to my mechanic friend who cleaned the gear linkages out and it's alot smoother now.

Hope that helps
Kelly is offline  
Status: -
AO Member
stace1000's Avatar
Join Date: Feb 2007
Posts: 49

Member car:

Alfa 147

Re: Got my new 147, just a couple of things puzzling me!


I'm no techie, but the gear thing is a common problem. I read the fix on here a while ago as mine was exactly the same.

Try a few searches for sticky gear knob or something. This worked a treat for me and has been the cheapest and best fix of the car's life.

Good luck...
stace1000 is offline  
Status: The Italian Job III
Club Member
Membro Premio
Andyman's Avatar
Club Member Number: 7
Join Date: Jul 2006
Location: In the house.
Posts: 1,551
Images: 40

Member car:

GT Cloverleaf

Re: Got my new 147, just a couple of things puzzling me!

Hi Danny,stiff gear nob is common,as Kelly & Stace said.
re the radio code,you can get this from alfa dealer,may cost you £10 - £15 for the code though.
Andyman is offline  
Status: -
AO Member
Join Date: Sep 2004
Location: Nr Wigan
Posts: 161
Re: Got my new 147, just a couple of things puzzling me!

yup, when the car is fully registered in your name, take it to an Alfa Dealer and they will get the code for you. Costs £20+VAT and you get the stereo code plus all other codes for the vehicle. Once you get it - keep it safe!

R to the D
royster-doyster is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , couple , puzzling , things

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome