147 - Changed battery, same faults - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Hmmm 147 - Changed battery, same faults

Well I changed the battery without incident , but am still showing an ABS & VDC error , as well as a new one saying service in 0 miles (that may be an old one though, not sure ).

Should I leave the battery disconnected for a day? Will this reset my fault system? I really don't believe that all these faults are occurring at once as if by magic, and I also don't believe it is a broken ECU as that is just a dealer cop out answer to everything and to fleece me


Sponsored Links
Status: -
AO Member
Join Date: May 2006
Location: Yorkshire,England
Posts: 159
Images: 4
Re: 147 - Changed battery, same faults

I had vdc abc faults on my 147 and it turned out to be the brake pedal switch, the guys on here told me to change it and it worked
AlfaGTA 156 Mad is offline  
Status: 251bhp/300Nm dynoed :)
AO Car Of The Year Winner 2015
Membro Premio
gotcha's Avatar
Join Date: Dec 2003
Location: Slovakia
County: Bratislavsky
Posts: 3,176
Re: 147 - Changed battery, same faults

Visit your dealer and let him reset all warnings on examiner. Battery disconnecting will not help. If they appear again, start looking for the fault. If they don’t, it was just electrics playing with you.
gotcha is offline  
Status: -
AO Member
Ben B's Avatar
Join Date: Nov 2006
Location: Bury St Edmunds, Suffolk
Posts: 341
Images: 12
Re: 147 - Changed battery, same faults

I had a VDC & ABS Faults too. I was told the sensor (each hub has one so there's four to check) can get dirty and simply need blowing clean with an airline. The same sensor works both systems that's why the error comes up together.

With me however it turned out that I'd fitted the ABS wire wrongly and the tyre had worn through the cable! oops!
Ben B is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , battery , changed , faults

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome