156 jts p0154 error. motor circuit error - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 28-05-15 Thread Starter
Status: -
Join Date: May 2015
County: -
Posts: 1
156 jts p0154 error. motor circuit error

hey guys, I'm new so please be gentle.

I'm new to alfa's but no stranger to high maintenance cars.
right. Only had the car a month, 2003 jts with 53k miles.

I have the multi circuit error coming every week or so sometimes upto 2 weeks. I have fiat ecu scan (free version at mo)
get p0154 lambda 2 signal above catal

so, I did some logging.
engine temp 78 degrees c

lambda 1 signal pre cat 2.13 - 2.179 fluctuating -open loop
lambda 2 signal pre cat 1.512 steady -open loop
lambda 1 signal after cat 0.030 steady -open loop
lambda 2 signal after cat 0.226 steady -open loop

mass air flow 2.7 kg/h
air quantity 15.3 kh/h

Battery volts running 13.93 engine off 12.04

Car runs fine, idles fine, just annoying when light comes on and buzzer scares you at 05:30am!!
I'v read a few things about low battery volts , bad wiring connectors... Do my readings help with anything?
I do have a slightly bodged intake pipe, rubber pipe sealed up. I am going down the v6 mod road but would an air leak cause the duff signal from lambda?

Any suggestions appreciated.
I did strangely find a new lambda sensor in glovebox when I purchased :/

It's in an alfa specialist in couple weeks for a cambelt and service but I'd like to have this sorted so attention can be paid elsewhere
mill5y is offline  
Sponsored Links
Status: 159 2.4 20007 plate 19,500 DPF/EGR by Adie (AHM)
AO Silver Member
Join Date: May 2009
Location: United Kingdom
County: Wiltshire
Posts: 2,267
Images: 16
Yes, an air leak wil cause chaos.
kandlbarrett is offline  
Status: -
AO Member
Join Date: Mar 2014
Location: cheshire
County: Cheshire
Posts: 43
I have exactly the same error. Can runs fine and then alert comes on totally at random after no specific mileage / time. My lambda sensor on the other side has already been replaced so probably go for this sidevwhen I get time.
adarlo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , circuit , error , jts , motor , p0154

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome