overboost Valve - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 17-05-15 Thread Starter
Status: -
Join Date: May 2015
County: -
Posts: 1
Hmmm overboost Valve

hi all,

I have a problem with with my alfa 147 Jtd,

I get the following error using alfadiag "Overboost Valve"

whilst monitoring the engine whilst driving i have noticed that the target Overboost and the overboost measured are not corresponding,

Please see attached screenshot.

I am unsure if this is an actuator problem or the sender with the 2 small pipes on

Any advice will be great

Attached Images
File Type: jpg alfa.jpg (107.7 KB, 10 views)
TheMog is offline  
Sponsored Links
Status: Flaps? What flaps?
AO Silver Member
_The_Editor_'s Avatar
Join Date: Oct 2014
Location: United Kingdom
County: Devon
Posts: 2,205
Does it come in at higher revs?

I believe this is usually either sticky VNT veins (within the turbo), or leaks on the VNT vacuum hoses/actuator outside.. At high revs the veins on the exhaust turbine redirect the exhaust gas to bypass through the turbine rather than spinning it, thus creating lower boost...

If the veins are sticking, they won't move properly and you get overboost at the top range of the revs... If there's faults in the vacuum actuation system, the veins don't move properly and you get overboost again..

Worth checking over all the vac hoses for splits/cracks etc., very cheap fix if this is what's wrong!

_The_Editor_ is offline  
Status: -
AO Member
Join Date: Jun 2010
Location: Romania
County: Bucuresti
Posts: 34

Member car:

Alfa Romeo 156

Check the thin hoses that go to and from the VNT and boost control valve. Perhaps of them is cracked and your VNT is not moving.
IRBaboon is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

overboost , valve

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome