Interior Fan Switch Problem? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 28-07-07 Thread Starter
Status: -
Dogs Nob's Avatar
Join Date: Jul 2007
Location: Nottingham
Posts: 8

Member car:

156 Selespeed

Help Interior Fan Switch Problem?

Hello all. First time using this website. I'm desparate for help, and from other threads, I see you guys seem to know what's what.

My interior fan doesn't switch between any positions. It was stuck on 'de-mist', then it was stuck on 'forward'. Currently it's blowing away but no real air-stream is coming from any of the fans. Also, since having the air-con re-gassed, it seems to be maing a hell of a vibrating noise.

Oh, and while I'm at it, the headlamp light on the dash illuminates for about 10 seconds consistently on start-up, ten gos off unless I switch the headlamps on, of course). What's THAT all about?

Any ideas? I really don't want to pay Alfa hundreds of pounds to plug it into the diagnotics machine... I've heard about Alfa electrics, but this all seems a bit extreme. Thanks in advance!
Dogs Nob is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

fan , interior , problem , switch

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome