156 2.4 Jtd not enjoying the weather - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 24-07-07 Thread Starter
Status: -
AO Member
Join Date: Feb 2007
Location: Cheltenham
Posts: 32
156 2.4 Jtd not enjoying the weather

I live in Cheltenham, Gloucestershire and needless to say it's pretty wet at the moment!

I haven't used my car much since all the rainfall and flooding - seemed pointless putting my car at risk when I could walk everywhere and just get wet feet!

However, last night I did drive to the supermarket and my car was not too happy. Was 'juddery'... seemed to misfire on occasion, run like cr@p, then eventualy settled down as normal.

I'm wondering if the MAF is on it's way out... it's not the first time I have had this issue in damp weather.

Any suggestions peeps?!
kizzsmyth is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: 156 2.4 Jtd not enjoying the weather

With as much water in the atmosphere as there is, combined with lack of use, then you probably just have a temporary short in one connection or another due to damp. Don't leap to a MAF conclusion until the car has had a fair chance to dry out and have a good run.

Mine bleeps up a warning on damp mornings, but it goes as soon as it warms up, so its a false warning on mine.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , enjoying , jtd , weather

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome