Driven mad - Knocking after replacing entire suspension assembly - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 28-04-15 Thread Starter
Status: -
AO Member
CeReD's Avatar
Join Date: Sep 2012
County: -
Posts: 166

Member car:


Driven mad - Knocking after replacing entire suspension assembly

So I've had the odd knocking noise which has been cured by new parts, and for two blissful weeks there's been no knocking... However a knocking/clicking noise has started when:

- Going over bumps
- Accelerating and then braking in quick succession
- Going around corners that aren't flat

It's not a loud clunk/rattling noise, it's just a scratchy 'click' noise, quite hard t explain but happens on nearly every noticeable bump

My car's had all genuine alfa: anti rollbar replaced, upper wishbones, lower wishbones, droplinks and springs in the last 3-4k miles/6-8months. The top mounts appear solid (Can't rock them and the garage didn't pick up any issues when putting in the new eibach springs). Track rod ends appear solid. I'll be taking the wheel off and checkign every nut & bolt on the wishbones etc are solid and putting silicon spray on the bushes to see if that does anything.

Any ideas? It's infuriating -_- Thanks in advance for any help and advice
CeReD is offline  
Sponsored Links
Status: -
AO Silver Member
scottyf's Avatar
Join Date: Jun 2012
Location: United Kingdom
County: West Midlands
Posts: 5,173
Images: 26

Member car:

Alfa 166

make sure the bottom arm's on the four bolts are torqued up nice and tight. Bet they are sliding a little and hitting the ridge on the sub frame.
scottyf is offline  
Status: loving the alfa
AO Member
rc_addicted's Avatar
Join Date: Mar 2015
Location: United Kingdom
County: Surrey
Posts: 883

Member car:

147 jtd 16v mjet

Make sure the top mounts are tight
rc_addicted is offline  
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,286
Images: 12
Originally Posted by scottyf View Post
make sure the bottom arm's on the four bolts are torqued up nice and tight. Bet they are sliding a little and hitting the ridge on the sub frame.
But not too tight .. you run the risk of threading the mounts as they as in alloy and soft welded captive nuts ...

Yes, I have the T-shirt!
gazza82 is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,618
Pud237 is online now  
Status: -
AO Member
stevepx's Avatar
Join Date: Jul 2010
Location: United Kingdom
County: Hampshire
Posts: 174
Images: 10
Exhaust?? is it lose and knocking under the car... can sound like warn suspension..
stevepx is offline  
Status: -
AO Member
SpoiledGT's Avatar
Join Date: Dec 2014
Location: United Kingdom
Posts: 143

Member car:

Gt 3.2 v6

Could be Cv joint bearings
SpoiledGT is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

assembly , driven , entire , knocking , mad , replacing , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome