alfa 156jtd lack power below 2.5k - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-07-07 Thread Starter
Status: -
Join Date: Jun 2007
Location: Rugby
Posts: 3

Member car:

alfa 156 2.4JTD

alfa 156jtd lack power below 2.5k

Hi Guys,

Just getting used to the Alfa forum, posted my question in the into section!!

Have a bit of problem with my Alfa (nothing new there ). Its a 2.4 JTD done 127k miles. Its a 01 plate. Basically below 3k revs the car is dead, once it slowly picks up speed, after 3k its fine. Checked the pressure and the boost pressure seems to be in range, so I assume that rules out the turbo!! Also I think its running really rich as the dumps white smoke at low revs. Any ideas of what could be the problem?

af51 is offline  
Sponsored Links
Status: -
AO Member
Paul J's Avatar
Join Date: Nov 2006
Location: United Kingdom
County: Berkshire
Posts: 874
Images: 4
Re: alfa 156jtd lack power below 2.5k

Sounds like it could be the MAF.
Paul J is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156jtd , 25k , alfa , lack , power

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome