156 Warning Light Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
156 Warning Light Problem

Hey fella's,

My 'Lights Failiure' warning light has come on, uh oh spaghettio's!!!

Checked all around the car to make sure every light was working, even got a passer by to check my brake lights were working and every thing's spot on.

Have turned the car on and off a few times to see if this jimmies the problem outta there to no avail.

What could this be do you reckon? Theres obviously no problems with the bulb itself as they ALL work, including indicators. Every light has been checked and is operational. But this warning light just won't go away! Possible wiring fault? Or buggered fuse?

Please help, as I will love you always and forever, lol.

Sponsored Links
Status: only got a renault truck
AO Silver Member
jason156's Avatar
Join Date: May 2007
Location: United Kingdom
County: Powys
Posts: 3,013
Images: 10
Re: 156 Warning Light Problem

If its the brake light it will come on and off with the brakes ( mine did)
At the moment I have a side light out which has the warning light on
It isn't lit by all of the bulbs but check the dull ones like the number plate lights etc.........Good luck
jason156 is offline  
Status: - Update
Posts: n/a
Re: 156 Warning Light Problem

Oh yeah I didn't check the reg plate bulbs, let me just go and check...

Right, back, and Jason; I think I love you, lol

Turned out it was the left hand side rear registration plate light that had gone out, I gave it a quick tap and it came right back on. Tapped it some more to see if that caused it to go out again and it didn't. Checked the dash and the warning light has now disappeared.

Thank's mate, problem solved for the time being and all is well, lol.

Status: Fixing all your keys !!
AO Silver Member
Chris's Avatar
Join Date: Mar 2001
Location: United Kingdom
County: Tyne and Wear
Posts: 3,806
Images: 2

Member car:

a very dirty car

Re: 156 Warning Light Problem

Chances are that the reg light has actually broken. For some reason the filament breaks but can be tapped to reconnect it for a while. The next big bump you go over will break it again. You can often get them to last for a few months by tapping but one day it won`t work any more so you may as well change it soon.
Chris is offline  
Status: Still engineering
AO Silver Member
Old Engineer's Avatar
Join Date: Mar 2003
Location: Esher
County: Surrey
Posts: 1,929
Images: 12
Re: 156 Warning Light Problem

Not on mine! This seems to be an oddity with 156s. Frequently I turn on the lights and get the warning light. I know to get out and thump the bumper to get the nearside plate bulb working. It's always the nearside. It always stays on for the rest of the journey. In fact, it doesn't matter how hard you thump it again it won't go out - until the next time you start up and the bulb is cold. I've taken it all apart, cleaned every face, checked the voltage, changed the bulb; yet the next journey it's failed again.
I wonder if I swapped the units what would happen?
Old Engineer is offline  
Status: - Update
Posts: n/a
Re: 156 Warning Light Problem


Mine was the nearside as well mate, looks to be a common problem then, this is the first time its done it though so hopefully it wont do it again. But I'm just wishful thinking, lol.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , light , problem , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome