Help!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 29-06-07 Thread Starter
Status: -
AO Member
wisemen's Avatar
Join Date: Jun 2007
Location: Yorkshire
Posts: 70
Help Help!!!

Had the car about 2 weeks now and a couple of faults have arose. Firstly the airbag light comes on and goes off when it feels like it. Secondly the engine management light has come on tonight, saying take to dealers. Any ideas of what either of these are likely to be, what the likely repair is for the problems and how much? Thanks guys.
wisemen is offline  
Sponsored Links
Status: Considering a ReMap
AO Silver Member
147virgin's Avatar
Join Date: Nov 2006
Location: United Kingdom
County: North Lanarkshire
Posts: 2,937
Images: 2
Re: Help!!!

Could just be needing a new battery or ECU. Think there's some threads on here on the ECUs.
147virgin is offline  
Status: alfa gt jtd
AO Member
slickdeville's Avatar
Join Date: Jul 2005
Location: Ireland
County: Clare
Posts: 184

Member car:


Re: Help!!!

just get a fault code reader...hook it up and read the faults.

post the fault codes here an somebody will tell you whats up with the car.
slickdeville is offline  
Status: - Update
Posts: n/a
Re: Help!!!

what 147 said...get the battery checked first..classic sign of it going flat...


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome