Hazards and indicator lights dead - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 13-03-15 Thread Starter
Status: -
Join Date: Mar 2015
Location: United Kingdom
County: South Yorkshire
Posts: 1

Member car:

Alfa Romeo 147

Help Hazards and indicator lights dead

This week a new problem was added to the many problems my ALFA 147 is experiencing this month, first one morning found a 10inch crack on my windscreen, Airbag lights pops up and no-one can return it to normal, then one morning stereo stopped working, zero sound comes out even when the display shows its working. Have had it looked at by someone who confirmed the stereo was working well, who also tested speakers in the car and confirmed they worked fine, but together no sound comes out (sounds like me and new my wife problems). Then this week the Hazards and Indicators lights bailed on me whilst i was on the way to drop my son to his nursery. First been told it might be wiring related issue or body computer. Took it to a nearby mechanic (first encounter with him), he said he found a problem and got me buying a second hand indicator stalk, on replacing it he now tells me i have to get rid of my first love (said its unreliable but have had for nearly 3 years with no problems). He reckons the body computer is causing all these problems and needs changing but he says its not worthy it as its too expensive and time consuming to do the job. so am wondering if there is anyone who might know how i can solve this HAZARD n INDICATORS problem, as didnt want to get rid of this lovely car.
AlfaNewby is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

dead , hazards , indicator , lights

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome