GT JTD chugging under 1500rpm - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 08-03-15 Thread Starter
Status: -
AO Member
alistair88's Avatar
Join Date: Jun 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 145
Images: 8
GT JTD chugging under 1500rpm

Hi guys,

I've had my Alfa GT since January of this year. It's a 2006 1.9 JTDm 16v 150bhp model. Before this I've previously owned 2 147 JTD 8vs and have never experienced this issue.

Just to give a small back story, the GT broke down in Wolverhampton a couple of weeks ago. Literally lost all power and then the car wouldn't start. The AA came out, and told me it was a problem with the EGR valve. Had it replaced, but ever since the car just hasn't been happy.

When I'm driving over 1500rpm, the car seems normal - no problems at all. Anything underneath that, and it's almost like it's coughing and extremely under rev'd. When sitting stationary, the entire car shakes. It also struggles to start sometimes too. I originally thought it was a stuck injector problem, but have been told it could also be a turbo issue. Could anyone on the forums advice me as to what the most likely issue is? Thank you in advance!
alistair88 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

1500rpm , chugging , jtd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome