156 1.9 jtd 16v 2005., not pressure from pump - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 04-03-15 Thread Starter
Status: -
Join Date: Mar 2015
Location: Latvia
County: Talsu Rajons
Posts: 1

Member car:

156 jtd

156 1.9 jtd 16v 2005., not pressure from pump

Hello. having issue of my alfa, pressure from pump is 70bar, pump is restored, line pump working well, imobilaser is ok, engine computer with key and imobilaser was changed... I don't now what to do now.. HELP
edzisgars is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jan 2014
Location: United Kingdom
County: Essex
Posts: 432
Welcome edzisgars,

Don't take this as the word of an expert, because I'm not, but if it happened to mine I would check the fault codes for pressure regulator faults, (looking for open or short circuits). Then pull the injector return line off the fuel collector tank (on mine it's above the HP pump), plug the tank port, and watch for fuel flowing from the injector return line during cranking. If it does then an injector is leaking, preventing the pump from generating sufficient pressure.

If the 70 Bar reading came from the car's sensor, perhaps it is reading low, and the pressure is actually there (though what stops the pump over pressurising the system in this case I don't know). You could get the sensor checked by an injection specialist, or try another.
R.T. is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 16v , 2005 , jtd , pressure , pump

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome