Leak of water into the A-pillar of my 156 (2002)... help! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Leak of water into the A-pillar of my 156 (2002)... help!

Hi Everyone

I've had my 2002 156 JTS for about 4 months, and no leaks of any kind! No sign of staining on the A pillars either, so it sounds like it has never leaked…

It's been very rainy here in Australia over the last week, and the other day I noticed a stain on the passenger side A pillar (front) trim, from water leaking! I was kinda shocked as you'd imagine…

I'd love some suggestions as to the cause. My mechanic checked the sunroof drains and they seem to be working fine, so I don't think it's a sunroof issue.

Here are some thoughts:
- Could the windscreen seal be leaking?
- The car was parked on an uphill slope in heavy rain the other night, could this have caused a problem?
- The other night I opened the door in heavy rain for my wife, who then stood under her umbrella talking for another five minutes… I pulled the door closed but it didn't quite click closed, could water have leaked in that way? I can see how it might trickle onto the seat but having looked at the seal, I don't see how this could have let water run into the A-pillar…

I'd love to hear any suggestions as to the cause / solution / ideas about this problem… I know there are lots of leak-related posts but I'd love to hear thoughts on the A-pillar leak issue as most of those concern leaking to the rear pillars.

Any info or ideas would be really appreciated!

Sponsored Links
Status: Generating blue smoke. Lots of it!
Club Member
Membro Premio
Probusterrace's Avatar
Club Member Number: 25
Join Date: Jul 2006
Location: United Kingdom
County: Shropshire
Posts: 2,701
Images: 14
Re: Leak of water into the A-pillar of my 156 (2002)... help!

Try searching for other threads about this problem.

There are a number of common causes of water leaks in this area, ranging from door seal problems to leafs in the drainage channels for the windscreen. Previous threads will give you all you need to know.

In your case it does sound like a windscreen fault. I've got a similar problem with my 147. Windscreen fitter I talked to the other day suggested it was probably a void in the sealant and would need the whole screen taking out/replacing!

Just bought a small tube of silicone sealant supposedly designed for the job. If I can figure out how to remove the surrounding trim without damaging it I will try to block the route of the water myself. At the moment when it rains, I get a soggy tax disk!

Good luck.

60% of the time it works everytime.
Probusterrace is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 2002 , apillar , leak , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome