rear brake light fix - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-02-15 Thread Starter
Status: -
Join Date: May 2013
Location: United Kingdom
County: East Sussex
Posts: 5

Member car:

2001 2.0 156

rear brake light fix


Like others I have encountered the 'one rear brake light not working/bulb fail light on when pressing brake problem.

My light was not glowing with ignition off so I discounted the rev counter fix recommended for that.

While searching I came across this on a fiat forum
Brake light problems-changing the switch - The FIAT Forum

While looking for the bit on the alfa, the cable that is attached to the brake switch above the pedal was very loose and it popped out while my hand was waving in the area.

I plugged back in and my brake light started working...

The bulb light still comes on when I press the brake but the actual light is working! I haven't gone on a drive so perhaps the bulb warning light will reset, but either way this seem to be related to the brake switch which it seems is a shared part with the fiat stilo.

This may save an mot fail for someone.

juliobango is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
Wiring can be an issue, but do remember that you should have 3 brake lights - one in each rear corner light, and the central one......
rgwm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

brake , fix , light , rear

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome