Vibrations after new clutch - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 10-02-15 Thread Starter
Status: -
AO Member
Join Date: Jan 2010
Location: United Kingdom
County: West Yorkshire
Posts: 176
Vibrations after new clutch

Hi All

I had a new clutch fitted a few weeks after my release bearing failed on me, they checked the clutch and said it didn't need a fly wheel replacement.

The car drove fine, nice soft pedal but it did judder slightly when setting off - which I was told drive the car steadily for a few hundred miles to bed the clutch in.

Now two weeks on the car still judders (slightly) but I can feel the idle quite strongly in the car and when driving you can feel the engine vibrations through the clutch pedal.

I'm planning on taking the car in tomorrow but I was wondering if anyone had any thoughts on what may be the problem>?
daryl is offline  
Sponsored Links
Status: loving my ALFA
AO Member
Join Date: Nov 2011
Location: United Kingdom
County: Tyne and Wear
Posts: 860

Member car:

alfa gt jtdm

could be the DMF
300stu is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clutch , vibrations

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome