Alfa GT 1.9jtd motor control system failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 03-02-15 Thread Starter
Status: -
AO Member
Hesse666's Avatar
Join Date: Jan 2015
Location: United Kingdom
County: Tyne and Wear
Posts: 23
Alfa GT 1.9jtd motor control system failure

Good evening I am after some help my alfa gt 1.9 jtd has started getting a intermittent warning light come on i would say it was once every 10 drives sometimes when starting sometimes when cruising but it still goes to 80mph and then the next time you start up its gone it also gets a vibration as well but this goes when you take your foot off the pedal

Hesse666 is offline  
Sponsored Links
Status: -
AO Member
Hugh Myles's Avatar
Join Date: Aug 2007
Location: Sligo, Ireland.
Posts: 790

Member car:

156 2.4 JTD SW

You need to get the codes read from the ecu.
Hugh Myles is offline  
Status: -
AO Member
Join Date: Oct 2014
Location: United Kingdom
County: Essex
Posts: 34
I've had the Motor Control System Failure warning too. Took it to my mechanic and after some time running checks and reading errors couldn't find a reason for it. He cleared the error and The GT ran fine for about a month.

Last month error showed up again.
However there seemed to be no impact on performance. Drove to work and on the way back there was no error on start up. Then last week the error pops up again.
However after some driving the error disappears on the next start up. looks to me like I have a battery on its way out. Thinking about it, on all three occasions the car had been sitting for a few days with no use.

Not sure about the vibration, but suggest you get your battery checked (as its quick and cheap to do )
Also get the codes read.
Arman084 is offline  
Status: turbo charger assembler
AO Silver Member
Join Date: Nov 2010
Location: United Kingdom
County: West Yorkshire
Posts: 1,928
as hugh please.......£15 obd2 reader from ebay with get them........write them down dont just delete them

without them its impossible to even guess
hdseven is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

19jtd , alfa , control , failure , motor , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome