Heater Fan/blower - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 02-02-15 Thread Starter
Status: -
AO Member
Join Date: Sep 2013
Location: Ireland
County: Clare
Posts: 19

Member car:


Heater Fan/blower

Hi all, I have 156, 1.8, 2001, still going !
When I bought the car setting # 2,3, and 4 worked on the blower/heater, (no aircon fitted), now setting # 2 no longer blows (common prob I think ), any simple fix I can do myself ?, without removing the upper and lower center console ( done that before to fix a wobbly handbrake lever !). Thanks in advance for any advise
mikegh is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
Its likely to be a fault in the resistor, rather than the blower itself. You can get at the resistor without dismantling any of the centre console - its mounted just inboard from the heater blower.

However the resistor for the non-aircon cars is much rarer and harder to find than that for the aircon cars, so you may struggle to find a replacement.
rgwm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

fan or blower , heater

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome